Administrator Dashboard Loading ISsues
Incident Report for SurveyMonkey Apply
Resolved
The Dashboard issue has been resolved and a fix is now in place.
Posted Jun 29, 2023 - 12:04 EDT
Investigating
We're currently aware of an issue with SM Apply Administrator roles wherein the Site Dashboard is not fully loading for Administrators. Our Engineering team has been made aware of the issue and is currently investigating.
Posted Jun 29, 2023 - 11:05 EDT
This incident affected: Main Application & Customer Sites and Customer Sites (US Hosted).