Help Center Down
Incident Report for SurveyMonkey Apply
Resolved
We have resolved the issue with out Help Center, it may take a little bit of time to fully propagate (1 or 2 hours), so please be patient as it boots back up!

Apologies for any disruption this may have caused.
Posted Jan 07, 2022 - 14:35 EST
Identified
We have found the cause of the issue and are currently addressing
Posted Jan 07, 2022 - 12:02 EST
Investigating
Our Help Center is currently unavailable. We are investigating the issue and will provide updates as we receive them
Posted Jan 07, 2022 - 10:34 EST
This incident affected: Main Application & Customer Sites and Customer Sites (US Hosted).