Filtering issue within Manage Applications
Incident Report for SurveyMonkey Apply
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 18:55 EST
Identified
We are aware of an issue affecting the filtering function in Manage Applications strictly within the Administrator view of the site. Our team is working to resolve this as quickly as possible.
Posted Nov 08, 2024 - 14:57 EST
This incident affected: Main Application & Customer Sites and Customer Sites (US Hosted).