500, 502 Errors When Attempting to Access Site
Incident Report for SurveyMonkey Apply
Resolved
Our Engineering team has addressed the issue and are working towards a permanent resolution.
Posted Mar 18, 2021 - 16:13 EDT
Investigating
We are aware of users experiencing issues when attempting to access their sites. We are investigating and will provide updates as they become available. Thank you
Posted Mar 18, 2021 - 16:04 EDT
This incident affected: Main Application & Customer Sites.