Degraded services
Incident Report for SurveyMonkey Apply
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 15:25 EST
Investigating
We are investigating reports of intermediate-degradation on SMApply.
Posted Nov 25, 2021 - 11:23 EST
This incident affected: Main Application & Customer Sites.