Visibility and Display Issues
Incident Report for SurveyMonkey Apply
Resolved
This incident has been resolved.
Posted Dec 05, 2023 - 12:51 EST
Investigating
We’ve received reports of some users experiencing formatting issues when accessing SurveyMonkey Apply. Our team is currently investigating the issue and will provide continued updates as we have them.
Posted Dec 05, 2023 - 11:41 EST
This incident affected: Main Application & Customer Sites and Customer Sites (US Hosted).