Resolved: Administrator Dashboard Loading Issue
Incident Report for SurveyMonkey Apply
Resolved
During today’s scheduled release, some users briefly encountered errors when loading parts of the admin dashboard. The issue has been resolved, and full functionality has been restored. We apologize for any inconvenience and are working to prevent future occurrences.
Posted Oct 16, 2024 - 11:30 EDT