SM Apply Sites hosted in Canada are not functioning properly

Incident Report for SurveyMonkey Apply

Resolved

Issue related to functionality of sites hosted in Canada has been resolved.
Posted Jul 02, 2025 - 09:26 EDT

Investigating

Only sites hosted in Canada are experiencing this issue. The sites load but are not functional. Please note: US hosted sites are not affected.
Posted Jul 02, 2025 - 08:39 EDT
This incident affected: Main Application & Customer Sites.